Problema com Shop0 e Itens

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
Pessoal estou com alguns problemas que estao dificil de resolver.
Como um problema puxa o outro acredito que resolvendo um tambem vou conseguir resolver o outro

Entao vamos ao primeiro...
Editei a SH Plate no meu bk, quando logo na conta ela aparece mas quando clico no personagem ela some veja:




O Outro problema é quando eu ligo o game server da o seguinte erro:

Entao para tentar resolver deletei todos os itens, após ligar novamente ele roda sem nenhum erro.
Porem os itens que estou tentando editar sao itens simples veja:


E no shop aparece dessa forma:




Desde já agradeço e boa vontade dos que se protificarem a ajudar
 
 

MuWord

Usuário XPZ
20 de Outubro de 2013
380
185
43
25
www.hardteam.net
Quando você disse que editou o shield plate, me fale o que você fez.

em relação ao NPC, tente adicionar os itens manualmente, é simples e é aprova de erros.

Estou no aguardo.
 
  • Like
Reactions: xpzone001

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
Editei com o MuEditor2.1.
Refiz esse teste adicionando a shield plate no inventario e no personagem mas ela não aparece.
Eu costumo adicionar itens no shop um por um sem usar programas, depois de uma certa quantidade da erro.
Nesse caso eu usei esse programa só para exemplificar.
 
Editado por um moderador:

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
Veja outro teste feito:
Removi os itens que nao estavam aparecendo no shop0 e adicionei a shield plate (shild iron no item.txt) quando clica para comprar ela vem para o inventario mas quando reloga com o personagem ela some
 

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
O servidor original possui 4 dataservers e eu só abria 2. Ate entao nunca deu erro.
Porem agora com esse problema eu substitui os que eu tenho pelos originais e abri os 4 porem foi uma tentativa sem sucesso...
Restaurei as databases também mesmo assim não deu certo
 

magtjr

Honrado XPZ
24 de Março de 2013
416
93
28
32
Cara pelo que vi teu shop ta com caracteres invalidos, tipo o nome dos itens, se nao me engano deve por um // de comentario depois deles, nao um -traço. exemplo

7 11 7 36 0 1 3 0 //Silk Helm
7 12 7 42 0 1 3 0 //Wind Helm
7 13 7 48 0 1 3 0 //Spirit Helm
7 14 7 55 0 1 3 0 //Guardian Helm
8 11 7 36 0 1 3 0 //Silk Armor
8 12 7 42 0 1 3 0 //Wind Armor
8 13 7 48 0 1 3 0 //Spirit Armor
8 14 7 55 0 1 3 0 //Guardian Armor
9 11 7 36 0 1 3 0 //Silk Pants
9 12 7 42 0 1 3 0 //Wind Pants
9 13 7 48 0 1 3 0 //Spirit Pants
9 14 7 55 0 1 3 0 //Guardian Pants
10 11 7 36 0 1 3 0 //Silk Gloves
10 12 7 42 0 1 3 0 //Wind Gloves
10 13 7 48 0 1 3 0 //Spirit Gloves
10 14 7 55 0 1 3 0 //Guardian Gloves
11 11 7 36 0 1 3 0 //Silk Boots
11 12 7 42 0 1 3 0 //Wind Boots
 
 
  • Like
Reactions: xpzone001

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
magtjr
Boa observação
Mas nesse caso ai eu adicionei os itens com o programa e acertei colocando o "//" na frente, sempre que uso esses programas eu verifico antes de abrir o gameserver se tudo esta certo.
Também verifiquei se todos os itens estão presente na pasta kor e estao la sim.
Com isso ai eu ja to esperto hehehe
 
Editado por um moderador:

CronusMakerchanel

MAPSMAKER,3DMaker,MuHelper
Moderador
Super Moderador
19 de Novembro de 2011
7,080
2,068
133
26
Santo Antonio do descoberto-GO
www.facebook.com
na 99 o mushop final tem de se adicionar mais numeros ja que ele ja le exlenete e anciente em alguns ms

ou seja ao inves de 6 digitos usa 7

0 0 0 0 0 0 use desse aqui 0 0 0 0 0 0 0 ou seja adicione um zero ao final do codigo

ja sobre o iten sumir e por que ele não esta habilitado para aquele personagen ou seja no iten(kor) ele esta tipo abilitado para bk e não para DK ou seja se entrar com um dk o iten de bk some
 
  • Like
Reactions: xpzone001

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
Conferi item por item e todos estao com 7 digitos...
Quanto a permissao para o personagem usar ou nao o item, fiz o seguinte teste:
Adicionei a shield plate ( somente ela) no shop0 e entrei com um Dark Lord, realizei a compra do item e ao relogar ela simplesmente desaparece.
Veja os novos testes:



TODOS ESSES SHiELD'S FORAM ADICIONADOS NO SHOP0 E SOMENTE 1 APARECE:



NESSA IMAGEM ESTOU CONFERINDO OS ITENS DO SHOP0 COM OS ITENS DO ITEM KOR
VEJA QUE O CODIGO ESTA CERTO:




Galera eu ja nao sei mais oque fazer...
Nao posso simplesmente trocar de MuServer porque ja estou trabalhando nesse ai a meses para deixar do meu geito.
Por isso qualquer dica é muito bem vinda.
 

MuWord

Usuário XPZ
20 de Outubro de 2013
380
185
43
25
www.hardteam.net
Trouxe uma luz para voce

 

//---------------------------------------------------------------------------------//

//Index Item Lvl Dur Skill Luck Opt Nome   //

//---------------------------------------------------------------------------------//

 

12 16 0  0 0 0 0 //Fire Slash

 

Ai descreve o nosso ferreiro de lorencia e o que cada numero da linha significa, é só seguir o padrão.

 

Exemplo : vou adicionar uma shot sword

 

0 1 13 255 0 0 0

 

0 => index do item

1 => numero da espada na categoria 0 (swords)

13 => level do item no ferreiro

255 => durabilidade

0 => skill

0 =>luck

0 =>options adicionas (dano adiciona +28)

 

Não tem mais como errar em


 

Caso não funcione, verifique seu item.bmd , ele que é responsável pelo item não aparecer no servidor mesmo estando adicionado ao item.kor (txt)
 
Editado por um moderador:

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
Ja conferi os códigos do shop e item kor varias vezes
Conferi também o item bmd e o ozj da pasta Data (no cliente).

Mesmo assim os itens não aparecem
 

xpzone001

Usuário XPZ
9 de Julho de 2012
40
3
8
troquei o meu cliente por esse do mudd mesmo assim não resolveu
esta com o mesmo problema.
Fiz um teste adicionando as shields no shop1 e elas também não estão aparecendo
 

MuWord

Usuário XPZ
20 de Outubro de 2013
380
185
43
25
www.hardteam.net
Baixe o muserver novamente, extraia na pasta e configure novamente, eu sei que é chato, mais é melhor do que quebrar o crânio.

Pois algum arquivo certeza corrompeu.