Executavel aceitnado qualquer Items.OTB

BLuMasTeR

Honrado XPZ
30 de Agosto de 2009
46
2
0
31
www.kingsworld-dev.webnode.com
Bem, eu vim aqui postar a resolução de um problema que eu percebi ser bem comum, o erro que nós vamos consertar é o do

Unable to load items.otb

Vamos lá:

Vá na pasta onde ficam as sources do seu executavel e procure por items.ccp, abra ele pelo modo editor(ou pelo seu programa de compilar) e procure por:




if(Items::dwMajorVersion == 0xFFFFFFFF)std::clog << "[Warning - Items::loadFromOtb] items.otb using generic client version." << std::endl;

else if(Items::dwMajorVersion < 3)

{

std::clog << "[Error - Items::loadFromOtb] Old version detected, a newer version of items.otb is required." << std::endl;

return ERROR_INVALID_FORMAT;

}

else if(Items::dwMajorVersion > 3)

{

std::clog << "[Error - Items::loadFromOtb] New version detected, an older version of items.otb is required." << std::endl;

return ERROR_INVALID_FORMAT;

}

else if(Items::dwMinorVersion != CLIENT_VERSION_861)

{

std::clog << "[Error - Items::loadFromOtb] Another (client) version of items.otb is required." << std::endl;

return ERROR_INVALID_FORMAT;
e substitua por esse:



/*if(Items::dwMajorVersion == 0xFFFFFFFF)  std::clog << "[Warning - Items::loadFromOtb] items.otb using generic client version." << std::endl;

else if(Items::dwMajorVersion < 3)

{

  std::clog << "[Error - Items::loadFromOtb] Old version detected, a newer version of items.otb is required." << std::endl;

  return ERROR_INVALID_FORMAT;

}

else if(Items::dwMajorVersion > 3)

{

  std::clog << "[Error - Items::loadFromOtb] New version detected, an older version of items.otb is required." << std::endl;

  return ERROR_INVALID_FORMAT;

}

else if(Items::dwMinorVersion != CLIENT_VERSION_861)

{

  std::clog << "[Error - Items::loadFromOtb] Another (client) version of items.otb is required." << std::endl;

  return ERROR_INVALID_FORMAT;

}*/
e agora é só compilar.

Explicação: Foi apenas adicionado a tag /**/ no script para anular essas linhas, ou seja inutilizar elas, fazendo assim com que ao ligar o server o seu distro não verifique a versão do items.otb, (e lembrando que nesses servidores mais recentes já existe uma opção no próprio config.lua que anula a verificação do items.otb)

OBS: Não olhei se ja existia um tópico com essa explicação.

Porem creio que vai ajudar muito.

Credito:

Nao encontrei dono do mesmo entao fica ( google )

Caso voce seja o dono do mesmo favor avisar para por seus creditos.

Blumaster por compartilhar