Linked Server

24 de Novembro de 2013
130
37
28
25
#21
Você tem que ativar os ips ativar os protocolos TCP/IP e Named Pipes ativar o ipv4 e restartar o SQL service
tb nao deu certo.

oq eu fiz foi baixar uma database chamada GAMEDB, e restaurei ela. Ai lá no SQL Manager fui Security>Login>SA>Propriedades e em defalt data base eu coloquei o gamedb.

porem agora o erro que aparece é esse:



To qse desistindo de fazer meu servidor de cabal :/
 
24 de Novembro de 2013
130
37
28
25
#22
tb nao deu certo.

oq eu fiz foi baixar uma database chamada GAMEDB, e restaurei ela. Ai lá no SQL Manager fui Security>Login>SA>Propriedades e em defalt data base eu coloquei o gamedb.

porem agora o erro que aparece é esse:



To qse desistindo de fazer meu servidor de cabal :/
Tentei criar um linked server através de um comando e deu certo, bom, pelo menos até agora deu tudo certo.

Vá no SQL manager, clique em NEW QUERY e coloque o seguinte comando:

EXEC sp_addlinkedserver

@server = 'GAMESERVER', -- nome com que o servidor sera conhecido no servidor

@srvproduct = '',

@provider = 'MSDASQL',

@provstr = 'DRIVER={SQL Server};INSTANCIA-PC/NOME;UID=;PWD=;'

 

Tomara que dê tudo certo agora
 
13 de Janeiro de 2014
48
11
8
21
#25
Tenso já to a horas vendo os tutoriais e alterando os ips e ainda ta dando stopped, alguém sabe algum outro jeito de para de dar stopped ?

Já vi esse Tópico> 

e o erro ainda continua se alguém souber pff me ajude  :c
 
Editado por um moderador:
29 de Junho de 2013
268
55
0
#26
Tente libera a porta 1433 no firewall ou desativa ele, se nao de pode ser esta com alguma configuração errada no sql com centos, que nao esta deixando haver conexão. qual centos vc esta usando?
 
Editado por um moderador:
18 de Julho de 2014
83
30
18
28
#27
Eu perdi a conta de quantas vezes tentei resolver este problema, então encontrei uma solução que me ajudou por tanto tentem e vejam se ajuda em algo.

Aqui tentei várias coisas e por fim deixei assim na configuração do SQL deixa igual todos tuto dizem IPv4 127.0.0.1 yes yes e  bla bla bla, ainda não hávia resolvido dai notei que meu usuário sa (security/logins/sa)estava com um flechinha para baixo dei botão direito - propiedades fui em status e deixei nas opições "Grant" e "Enable" depois digitei a senha do meu usuário e dei OK e agora sempre que vou ligar o servidor continua o erro porem ao dar propriedades e digitar a senha na aba general resolve e liga perfeitamente, e deixa o linked como localhost, aqui é só digitar o usuário que lige perfeitamente tenta ve se soluciona o de vocês ....
 
Editado por um moderador:
23 de Janeiro de 2014
17
0
1
#31
bom galera criar um servidor de cabal é facil o duro pra mim aki é editar e deixar do jeito q eu quero........

peço ajuda de alguem aki do xpzone pra ajudar eu editar o servidor colocar + canais e alguns itens e de como deixar online

obrigado galera e quem for me ajudar grato.........si alguem tever dificudade de criar um servidor posso ajudar tbm so entrar em contato no pm vlw......
 
1 de Julho de 2014
3
0
1
#34
Tentei criar um linked server através de um comando e deu certo, bom, pelo menos até agora deu tudo certo.

Vá no SQL manager, clique em NEW QUERY e coloque o seguinte comando:

EXEC sp_addlinkedserver

@server = 'GAMESERVER', -- nome com que o servidor sera conhecido no servidor

@srvproduct = '',

@provider = 'MSDASQL',

@provstr = 'DRIVER={SQL Server};INSTANCIA-PC/NOME;UID=;PWD=;'

 

Tomara que dê tudo certo agora
Só uma duvida , com a Query aparece o *GameServer* no Linked Server ?
 
26 de Abril de 2014
1
0
1
#35
Tentei criar um linked server através de um comando e deu certo, bom, pelo menos até agora deu tudo certo.


Vá no SQL manager, clique em NEW QUERY e coloque o seguinte comando:


EXEC sp_addlinkedserver


@server = 'GAMESERVER', -- nome com que o servidor sera conhecido no servidor


@srvproduct = '',


@provider = 'MSDASQL',


@provstr = 'DRIVER={SQL Server};INSTANCIA-PC/NOME;UID=;PWD=;'


 


Tomara que dê tudo certo agora
cara eu fiz isso e ele deu certo ,mas quando eu faço o teste nele ele da o mesmo erro como na imagem

Capturar.PNG